CiviCRM for Drupal 7 and Joomla 1.6

CiviCRM 4.0.0 has been released for the latest Drupal version – 7 and the new Joomla version – 1.6. Up until now it was necessary to install CiviCRM on the older Drupal 6 and Joomla 1.5.

Highlights

  • CiviCampaign has been integrated with other components such as CiviContribute, CiviMember, CiviEvent, CiviMail and CiviEngage
  • Joomla v1.6 introduced an ACL based permissioning system. This gets CiviJoomla to much closer parity with CiviDrupal.
  • CiviMember now allows membership upsell. This allows membership type to be changed on renewal
  • CiviCRM Extensions. You can now browse and download CiviCRM extensions from within your CiviCRM install.
  • A new API – version 3, introduces standardisation of functions, inputs and outputs.

For users of existing Drupal 6 and Joomla 1.5 CiviCRM installs, the simultaneous release of 3.4 for these versions includes the same features.

2020Media provides free installation of CiviCRM on all Drupal and Joomla hosting plans.

Published by

2020media

2020Media is a leading UK web host offering Linux and Windows website hosting. The company specialises in WordPress, Joomla and Drupal support.